Object Storage - IAD
Incident Report for CacheFly
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 14:49 CDT
Investigating
We are currently investigating a possible service impacting event for Object Storage service in the IAD region
Posted Apr 19, 2024 - 10:54 CDT
This incident affected: Origin - Object Storage.