MXP1 POP Outage

Incident Report for CacheFly

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 22, 2026 - 12:50 CDT

Investigating

We are currently investigating an outage in our MXP1 pop. We have routed traffic to the next nearest pop during this time.
Posted Mar 22, 2026 - 11:48 CDT